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 Document outline 

About the drawing protocol document 

Chennai Metropolitan  Development Authority has planned to automate the building plan approval 

process by introducing AutoDCR system. AutoDCR software reads the CAD drawings submitted by 

architects and automatically produce the deviation report based on the control regulations 

prescribed by CMDA. 

The purpose of this document is to establish a set of guidelines to Architects for preparation of 

drawings to be submitted for taking Building Permission from CMDA, Uniformity in the process of 

drafting of the drawings to be submitted for approval is required for automation of building 

approval system by introducing AutoDCR system.  

The consultants/Architects should prepare the drawings keeping specific objects in specific layers 

with specific colors and text.  The layers required to be generated with explanation of what is 

required to be drawn on which layer is described in this document. This document serves as a 

source of information on obtaining level of consistency in drafting and approval process focuses 

on both the theoretical and practical description of process flow and protocol to be used while 

preparing drawings for submission at CMDA for Building Permission. The document explains use 

of PreDCR utility.  

 

 How to read this drawing protocol document? 

http://www.uhuda.org.in/bye_laws/
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This document should be read in conjunction with the building bye-laws which will be applicable 

for approval of a proposal.  The reader of this document should have understood the applicable 

bye laws for scrutiny of a proposal. The reader should also be familiar with AutoCAD terminology 

and environment for better understanding of the system. It is more exploratory in nature than the 

specifications and contains sections to explain particular aspect of planning and designing. 

 

 

 

 

 

Drawing pre-formatting utility (PreDCR) 

 

Overview 

AutoDCR is a unique and innovative approach to automate scrutiny of building proposals by 

reading CAD drawings. AutoDCR software needs preformatted drawings with some specifications. 

PreDCR is a software application used to create the architectural plan as per AutoDCR software 

requirements. It helps in standardization of drawings and helps in reducing time required for 

preparing submission drawings. It works under AutoCAD environment with additional menu & 

toolbar. 
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Using PreDCR commands user can create all the required layers in one click. Once all the layers 

are created in the drawing user can use AutoCAD commands to draw entities on the 

corresponding layers with the help of PreDCR software. Short commands are provided to activate 

any layer in PreDCR. PreDCR also helps in correcting drafting errors in the drawing. At any time 

user can verify if the drawn entities are properly closed or not, if proper name text has been 

written inside all closed poly or not etc. PreDCR will highlight all the failed entities if any. 

 

 

Aims & objectives 

To bring uniformity and standardization in submission drawing format. 

To create error free drawing by auto-correction of drafting errors. 

To Increase drafting speed and efficiency 

To reduce drawing data redundancy. 

To remove dimensioning and area calculation requirements from submission drawing format and 

auto-calculating areas in AutoDCR automatically.  

 

Salient features 

Automatically creating required layers in the drawing 
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Automatically creating and inserting entites of required size in the drawing: User can define size 

of entity and insertion point in the the drawing.PreDCR will create and insert entity in the 

drawing at specified location. 

 

Automatic insertion of required text in the drawing. 
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Drawing cleaning, refinements of poly lines, text and closed entity verification will be done by 

PreDCR to eliminate drafting errors. 

 

 

PreDCR verify and will highlight failed entities in verifications with detailed explanation and Auto-

zooming. 
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Benefits of PreDCR 

1) Standardization of submission drawings-Brings uniformity & standardization in submission 

drawing format. This software will correct some minor drafting errors and also provide list of 

failed entities with Auto-zooming facility so that user can easily locate the failed entities in the 

drawing.  

2) Operational ease and convenience-Data redundancy is eliminated from the drawing. Only 

minimum required entities are to be drawn in the drawing as most of the data will be auto 

detected by the system from existing available data. 

3) Increased speed and efficiency-PreDCR facilitates Auto insertion of many drawing entities like 

parking, door windows etc of required size and number. Test auto-insertion facility saves text 

typing efforts. Auto-dimensioning and auto-calculation facility saves calculation efforts. Using this 

software user can create all the required layers at one click.    

4) Accuracy - Accuracy in area calculations is achieved. Preparing Calculation tables, showing 

dimensions in the drawing is not required.  
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Drawing formats 

 

1) Conventional submission drawing format  

 

 

2) As per PreDCR format specified by PreDCR  

 

 

3) After scrutiny of drawing using AutoDCR- 

Conventional drawing submission format 
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Protocol details 

 

PreDCR is a software application used to create the architectural plan as per AutoDCR software 

requirements. It works under AutoCAD environment with additional menu & toolbar. 

           Using PreDCR commands user can create all the required layers in one click. Once all the 

layers are created in the drawing user can use AutoCAD commands to draw layout plan. 

As per AutoDCR requirement all building items like proposed Plot Boundary, proposed work 

should be drawn on the corresponding layers. Short commands are provided to activate any 

layer in PreDCR  

At any time user can verify if the drawn entities are properly closed or not, if proper name text  

has been written inside all closed poly or not etc. PreDCR will highlight all the failed entities if any. 

          PreDCR can be used to modify/make and verify the existing or new architectural plan as per 

AutoDCR software requirements. Users are free to use AutoCAD commands and or PreDCR 
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commands to achieve the main purpose which is: 

Drawing the architectural plan in DWG format as per AutoDCR software requirements. 

For Automating the process of Development Control Regulations user/draughtsman/architect have 

to follow some specifications. The following are the list of specifications that the user should 

follow.  

Plot Boundary  layout, detailed floor plan and building section for all the floors should be there in 

one AutoCAD drawing file.   

All building items like proposed Plot Boundary , proposed work, proposed parking etc must be 

drawn using closed polyline. 

(i.e. Every entity must be closed LWPOLYLINE except Railway Line , Drain line, Water Line, Electric 

Line, DeadWall and Ground lvl.).  

Building Sub-Items must be exactly inside of outer closed polygon as per their place 

in architectural plan. 

This means none of the edge or vertex of inside entity should be drawn outside its container entity.  

       For example Parking or Open Space poly must be exactly inside the main Plot poly. 

       Tools are provided in PreDCR to verify this check.  

Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the same 

layer & inside the entity poly. If name not found then AutoDCR will generate the name 

automatically. Naming Conventions should be followed properly. 

e.g.  Each Room should be given the concerned name Using <Assign Name> function of preDCR 

Living, Kitchen, Bedroom..Etc.  

Floor Name: GROUND FLOOR; TYPICAL FLOOR 1,2 & 5-8; TERRACE FLOOR 

Floor Items: Room Names should be given properly without using abbreviations so the software 

can identify perfect entity. This can be done by Assign name facility provided by the software. 

User shall use only following kind of entities for Building Items :-  

LWPOLYLINE / TEXT / MTEXT 

If in a plan two proposed work are mirrored in that case user should provide two separate 

building plan for each proposed work. 

 

Installation and Registration 

System Requirements  
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         Pentium IV or better (or compatible processor) 

         1 GB RAM minimum 

         Windows 98/XP/2000/ 2007/2008 

         AutoCAD 2000 and onwards 

Installation 

To install PreDCR software on your computer please follows the given steps.  

Step 1:  Run the PreDCR installer by double clicking on file "PreDCR_Installer.exe"  

Step 2:  Follow the next steps in installer wizard to complete installation.  

 

After successful installation, a PreDCR shortcut will be placed on your computer desktop as  

shown below. 

 

Figure 1: PreDCR shortcut on desktop 

 

Methodology  

1)   Open the PreDCR software for clicking on PreDCR menu on your desktop & select the Autocad 

version & then click on "OK" button. 
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2)  First open submission drg which is now converting in PreDCR format. 

 

  

3)  Save as your dwg with give some name. 
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4) Check the scale by using Scale command. If drg is not in 1: 100 scale then covert into the 1:100 

scale. & then make that drg in metric scale if it is in other than meter.  

 

 

 

 

 

5) Also make the site plan in 1:100 scale. 
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6)  By using Predcr toolbar first select the Type of Project that is " Proposed Development“ , “Land 

Division” or “Plot Boundary Layout”  

a) If Plot Boundary  is Already sanctioned & user have to take permission for the buildings only 

then select “Proposed Development.” 

b) If User having Proposal is Amalgamation or Subdivision then select “Land Division” option from 

the list. 

c) If Proposal having a Plot Boundary ting Layout then select that “Plot Boundary ting Layout” 

option from the list. 
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7)  By using Predcr toolbar "Create a DCR layer" . 

 

Now Select current Layer is "_ Plot Boundary " & Draw a closed polyline on this layer. Also give 

the Plot Boundary  name on that layer only. 

 

 

 

Make the current layer '_Main Road” & Draw a road on this layer. Give the Name of road which is 

starting with it's width. 
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Make the current Layer " …….FSI" as per your project  having that use you can select that use of 

FSI. e.g. For Residential use - Select  "_ResiFSI"  poly, For Commercial use select “CommFSI” poly. 

& Draw a area key plan line on this layer. No need to give any name on this Layer 

 

 

Make the current Layer "_Carpet Area" and draw a closed poly on this Layer which having floor 
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area excluding wall area. Also give the name on this Layer. If carpet is splitted no of places but 

having only one tenement then use the Splitted tenement option from Predcr Mark menu bar.     

 

 

 

Make the current Layer "_Room" and draw a closed poly on this layer. If room having rectangle 

shape then u can use rectangle also. Assign the room name for using the assigned name option 

from Predcr menu bar. 

 



 

25      PreDCR help Manual : Chennai Metropolitan Devlopment Authority. 

 

25 Methodology 

 

 

: Insert the doors & windows by using insert option from Predcr menubar.  

 

 

 

 

15)  Make the current layer "_Floor" and draw a boundary outside of each & every floor. 
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16)  Make the current layer "_Tank" and draw U/G & O/H tank in plan as well as in section also. 

Assigned this tank name by using Assigned name option from Predcr  menubar. 
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17) Make the current layer "_Staircase" and draw all the riser on this layer which is a open  

polyline. Also draw two extra line on this layer which is showing a floor landing and intermediate 

landing. Then mark this landing for using staircase landing option from Predcr menu. Also mark 

the staircase which having type. For spiral and fabricated staircase no need to draw riser & 

landing marking. 
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 18)  Make the current layer is "_Ground Level" and draw a open polyline on this layer which is 

place below the plinth level. 
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Make the current layer is "_Building" and draw a boundary on this layer which is having a group 

of all the floors with section 

 

 

Make the current layer is "_ProposedWork" and draw a total coverage on this layer. Assigned this 

proposed work by using "Predcr->Assigned name -> Building & proposed work from Predcr 

menu. 
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If project having any Substructure then draw a closed polyline on "_Substructure" layer. Also mark 

this substructure by using " Predcr-> Mark-> Substructure from Predcr menubar. 

 

 

 

If project having any Existing structure then draw a closed polyline on "_Exstructure" layer. Also 

mark this Exstructure by using " Predcr-> Mark-> Exstructure from Predcr menubar. 
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Mark the margins by using Mark-> margin from Predcr menu bar 

 

 

 

Mark the margins by using Mark margin tab from from PreDCR tool bar.  

 

Front margin is automatically marked by system according to main access road. User need to mark 

side and rear margin only. 
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When Mark margin is done, Click on "Verify Closed poly" option from Predcr tool. 

 

 

 

 

 

 

 

:  When u will get these message "Entities on Predcr Layers are verified and found o.k." then only 

u can submit a softcopy of your drg to the Corporation. 
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 Also check the "Objection list" which user  are missing to convert in Predcr layer. 

 

 

You can check minimum entities are present on not in drawing according to selected type of project 

by using “Objection list” tab. 
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PreDCR Layer Information 

 _ArchProj 

Description :  

- This layer is used to represent various Architectural Projections in your Plan. Draw a closed Polyline 

for Architectural Projections. And mark it using Mark->Projection from PreDCR menu, according to 

requirements. Canopy/porch will come in Plot  & other projections will come with floor plans. 

Shortcut Command:-  AP 

How to draw : - 

_ArchProj:- 

 Following rules will be applied on the objects of ArchProj layer 

 Pergola 

 Planter box 

 F.Bed 

 C.B.( Wardrobe) 

 SunShade 

 Loft 

 Canopy ( 100% in FSI ) 

 Garbage Chute 

 Ornamental Projection 

 Portico (100% in FSI) 

 Service verandah 

 Verandah 
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 Otta 

 Steps 

 Precautions to be taken –  
 Draw polyline correctly. 
 Give name to this object from “Mark → Projection” option (From PreDCR Menu) 

 If this object has not been marked properly then it won't be checked.   

 

 

 

 

. _Balcony 

Description :  

Draw a balcony as a closed polyline which is a horizontal projection including parapet to serve as a 

sitting out place. Name of balcony must be inside and on _Balcony layer. 

Balcony can be present in :  

Plot Boundary : It must overlap with PWork (if not 

enclosed) 

Floor: It must overlap ResiFSI. 

Shortcut Command : BL  

How to draw : -   
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_Balcony:- 

 Following rules will be applied on the Objects of Lift layer   

 Balcony area  

 Balcony width 

 Precautions to be taken – 

 Draw polyline correctly. 

 Give name to this object from “Mark → Projection” option (From PreDCR Menu). 

 If  this object has not been marked properly then it won't be checked.   

 

                               

 

 _Building 

Description : 

Building is used to group all floor plans of the same building.   Draw a closed poly enclosing all the 

floor plans and section of the same building on _Building layer. Note: As written above, dimension or 

area of this building poly has no meaning in AutoDCR. This is just an logical group of all floors of the 

same building. If the building plan of multiple PWorks or wings are same then building name shall be 

as given in table below. 

Building names can be. 
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1  "A(Monarch)" PWork "A" has building plan 

"Monarch". 

2  "A,B(Monarch)" or "A&B(Monarch)" Wings A, B have same building 

plan "Monarch". 

3  "A-C(Monarch)" Wings A,B,C have same 

building plan "Monarch". 

4  "A1-A3(Monarch)" Wings A1,A2,A3 have same 

building plan "Monarch". 

Shortcut Command : BLD 

How to draw : 

_Building:-  

 Following rules will be applied on the objects of Building layer  

 Building & propwork At Mark on depend below rules will be check  

 Building height  

 Margin  

 Built up area 

 Total floor calculation 

 Consume fsi factor  

 Parking  

 Tenement density  

 Lift height  

 Staircase check 

 Per floor area 

 Floor Number Check 

 Subsidiary Structure Check  

 Precautions to be taken – 

 Draw poly line properly and give name to this object from “Assign Name → Building & 

PropWork” Option? 

 If  this polyline has not been draw and marking correctly then all above rules will not get 

checked        

       What Building poly will have? Building poly will enclose all the floor plans in that building along.              
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 _Carpet area 

Description :  

Draw carpet area as a closed polyline which is a net usable floor area within a building excluding that 

covered by the walls or any other areas specifically exempted from floor space index computation in 

these regulation. 

Shortcut command : CPT 

How to draw : -  

_CarpetArea:-            

 Following rules will be applied on the objects of carpet area layer  

 Per Carpet Tenement number check required  

 Parking car, scooter, cycle  

 Tenement density  

 Water tank  

 Sanitation  

 Precautions to be taken – 

 Draw polyline correctly Give name to this object in same layer as that of object  

 If this polyline has not been drawn and named correctly then all Above rules will not get 

checked.                   
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 _Chowk 

Description :  

Draw a chowk as a closed polyline which is an enclosed space permanently open to the sky within a 

building at any level. From chowk we take ventilation for habitual rooms. 

Shortcut Command : CWK 

How to draw : 

_Chowk :- 

 Following rules will be applied on the objects of Chowk layer 
 Area  
 Width 

 
  Precautions to be taken – 
  Draw polyline correctly Give name to this object in same layer as that of object  

 If this polyline has not been drawn and named correctly then all Above rules will not get 

checked.               

 

 



 

40      PreDCR help Manual : Chennai Metropolitan Devlopment Authority. 

 

40 PreDCR Layer Information 

 

_Column 

Description :  

Column shall be drawn as closed polyline on this layer. 

Shortcut Command : COL 

_CommFSI 

Description: Commercial FSI :  

Draw a CommFSI as a closed polyline which is the area covered by a building on all the floors. This 

FSI polyline mainly used for commercial use bldg. 

Shortcut Command :CMFS 

   How to draw: - 

_CommFSI:-  

 Following rules will be applied on the objects of ResiFSI layer  
 Permissible Balcony area  
 Built up area 
 Permissible FSI 
 Carpet area             
 Staircase             
 Room area  
 Arch projection 
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 Chock 
 Ventilation shaft 
 Passage 
 Lift 
 Terrace  
 Converge check  
 Precautions to be taken – 
 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked. 

      

               

 

 _CompoundWall 

Description :  

Open polyline of compound wall to be drawn on proposed compound wall with text started with 

compound wall height. E.g. 1.5m. high Compound Wall 

Shortcut Command : CW 

How to draw : -  

_CompoundWall:- 

 Following rules will be applied on the objects of Chowk layer 
 Height  
 Precautions to be taken – 
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 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked. 

 

 

 

Description :  

Draw open polyline overlapping with pwork on a side from where ventilation is not taken and 

should be draw inside the Plot Boundary  

Shortcut Command : DW 

How to draw : -  

_Deadwall:- 

 Following rules will be applied on the objects of Deadwall layer  
 Ventilation  
 Margin  
 Precautions to be taken – 
 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  
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_Door 

Description :  

Door is a closed Polyline Which is drawn on “_Door” layer. Also you can insert a particular size poly 

for Door using Insert->Door from PreDCR menu. 

Shortcut Command : DR 

How to draw : - 

_Door:- 

 Following rules will be applied on the objects of Door layer  
 Width 
 Depth 
 Height 
 Precautions to be taken – 
 Draw polyline correctly   
 Give name to this object in same layer from “insert “option  as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  
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_DriveWay 

Description : - 

Draw a closed polyline of drive way inside floor plan/layout plan and provide text with mentioning its 

width, also need to draw a center line on the same layer as open polyline.  

Mark drive way from PreDCR mark menu whether it is for cars, two wheeler or transport vehicle. 

_DwellingBUAOutline 

Description : - 

Draw DwellingBUAOutline as a closed polyline  which is a individual one tenement area  including 

all wall thickness. 
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  _ElecLine 

Description : - 

 Electric line will be present in the layout plan and shall pass through Plot Boundary  entity as a non 

closed polyline. 

Name electric line shall start with its voltage capacity and text insertion point shall lie on its polyline. 

  For e.g. 33 KV High Tension Line 

Shortcut Command : LI 

How to draw : - 

_Electricline:- 

 Following rules will be applied on the objects of electricline layer  
 Building distance check depend on 33kv high voltage & low voltage  
 Precautions to be taken – 
 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  
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 _Elevetion  

Description :  

Draw a elevation as a closed polyline which is a only outer line elevation  for printing  

  _EWS 

Description :  

Draw “_EWS” layer as poly line to define area of individual EWS units. 

_ExStructure 

Description: -  

Draw a Exstructure as a closed polyline which is a building or structure existing authorized before the 

commencement of these regulation. And mark it using Mark -> Existing structure as 'To be 

demolished' or 'to be retained’. 

Shortcut Command : EX 

How to draw :- 

_ExStructure:-  

 Following rules will be applied on the objects of Exstructure layer  
 To be retain  
 To be demolish  
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 Precautions to be taken –  
 Draw poly line properly and give name to this object from “Mark → Exstructure” Option? 

 If this polyline has not been drawn and named correctly then all above rules will not 
get checked  

 

 

 

 

 _Floor 

Discription: 

Draw a Floor as a closed polyline to the boundary of the lower surface in a story on which one 

normally walk in a building and including mezzanine floor also. The floor at ground level with a direct 

access to a street or open space shall be called the ground floor, the floor above it shall be termed as 

Floor 1 with the next higher floor being termed as Floor 2 and so on upward. For giving the name of 

each floor use the assign named option from the PreDCR menu. Also draw each floor separately. 

While giving name to the typical floor then use a Typical option from Assigned name -> Floor name 

option from PreDCR menu bar. 

Shortcut Command : FLR 

Reference Circle: - All Floor poly must contain a circle with its center on common point for whole 

building on layer "_ResiFSI". Usually it can be placed inside either Common Lift or stair/Inner Chowk 

as their locations are common for all floors. 
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Floor Name : - Floor name will be taken from text inside floor poly and on same layer. 

  A floor plan is automatically associated/linked by AutoDCR software with one or more floor section 

poly in Section plan. This is done by matching name of Floor Plan and FloorInSection so both must be 

same. 

Typical Floor Non-Typical 

"TYPICAL" X "FLOOR PLAN"X: Floor numbers 

in specific format (, or & or -) 

X "FLOOR PLAN" 

X: Direct Floor's Name 

e.g.: 

TYPICAL 1,2 FLOOR PLAN 

TYPICAL 1-4 FLOOR PLAN 

TYPICAL 2&3 FLOOR PLAN 

e.g. 

GROUND FLOOR PLAN 

FIRST FLOOR PLAN 

SECOND FLOOR PLAN 

How to draw :- 

_Floor:- 

 Following rules will be applied on the objects of Floor layer  
 Built up area 
 Inside all floor plan 
 Inside parking 
 Corresponding check  
 Total floor plan calculation  
 Per floor fsi calculation 
 Precautions to be taken –  
 Draw poly line properly and give name to this object from “Assign Name → 

FloorName” Option? 
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  
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 FloorInSection :  

Description :  

Draw a FloorInSection polyline as a closed poly of section boundary which contain all floors with stair 

cabin, Lift machine room, water tanks etc. as shown in the figure. Also write the name as "Section" in 

this section poly. 

In this closed poly of section draw sections of all floors with stair cabin, inner Chowk, Lift machine 

room, Ventilation shaft, water tanks etc. as shown in the figure. 

Also write the name as "Section" in this section poly. 

This section poly will present inside the building poly. 

Shortcut Command : SEC 

How to draw : - 

_ FloorInsection:-  

 Following rules will be applied on the objects of FloorInsection layer  
  Floor height  
 Terrace height  
 Plinth height 
 All Corresponding check 
 Precautions to be taken – 

 Draw poly line properly and give name to this object from “Assign Name → 
FloorName” Option? 
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 If this polyline has not been drawn and named correctly then all above rules will not 
get checked  

 

 

 

 

 _GroundLevel 

Description :  

Draw the Ground level line as open polyline in section .It is used for checking a total building height 

from this line. 

Shortcut Command : GL  

How to draw : - 

_Ground Level:-  

 Following rules will be applied on the objects of Ground level layer 
 Building  Height 
 Per floor height  
 Basement height  
 Plinth height 
 Average height check 
 Precautions to be taken –  

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
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 If this polyline has not been drawn and named correctly then all above rules will not 
get checked  

 

 

 

_IndFSI 

Description :  

 Draw a IndFSI as a closed polyline (area key plan line in the submission drg) which is the area 

covered by all the floors. Indusrial building means building or part thereof wherein products or 

material are fabricated , assembled or processed such as assembly plants, laboratories , power plans, 

refineries, gas plants, mills, dairies and factories. This polyline should be excluding balcony & terraces 

area. 

Shortcut Command :IFSL  

How to draw : - 

IndFSI :- 

 Following rules will be applied on the objects of ResiFSI layer  
 Permissible Balcony area  
 Built up area 
 Permissible FSI 
 Carpet area             
 Staircase             
 Room area  
 Arch projection 
 Chock 
 Ventilation shaft 
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 Passage 
 Lift 
 Terrace  
 Converge check  
 Precautions to be taken – 
 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked. 

      

 

 

 _DPRoad 

Description :  

Draw existing or proposed D. P. (Development Plan) road or T. P. (Town Planning) Road when 

inside/intersected with Plot Boundary . While giving name start text with road -width.E.g. 15m wide 

D.P. Road. 

Shortcut Command : R3 

How to draw : - 

_DPRoad:- 

 Following rules will be applied on the objects of intDProad layer  
 Width  
 Plot Boundary  area  
 Margin  
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 Deduction area  
 Precautions to be taken –  

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not get 

checked  

 

                                                                     

_InternalRoad 

Description :  

Draw internal road with text specifying its width as shown in figure. And draw a center line. And type 

of layer of the center line must be center line (Type of the Layer). 

Shortcut Command : R2 

How to draw : - 

_Internal road:- 

 Following rules will be applied on the objects of internal road layer   

      Width   

 Precautions to be taken – 

 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  
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 _Lift 

Description :  

Draw a Lift as a closed polyline which is a mechanically guided car, platform or transport for persons 

and materials between two or more levels in a vertical or substantially vertical direction. If fire lift are 

provided then use the marking of “Fire lift" option from Mark -> Lift -> Fire Lift. Fire Lift means a 

special lift designed for the use of fire service personnel in the event of fire or other emergency. 

Shortcut Command : LFT  

How to draw :  

_Lift :- 

 Following rules will be applied on the objects of Lift layer  
 Lift area  
 No of lift 
 width 
 height 
 Capacity  
 Free from FSI(paid & unpaid) 
 Taken in FSI 
 Hydraulic lift 
 Fire lift   
 Precautions to be taken – 

 Draw poly line properly and give name to this object from “Mark  → LIFT ” Option? 
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 If this polyline has not been drawn and named correctly then all above rules will not 
get checked  

 

 

 

 

 _LIG 

Description :  

Draw a “_LIG” layer as poly line to show area of LIG units. 

 

_Location Plan 

Description :  

Location plan if any to be drawn on this layer. This is only for reference. No verifications are done by    

AutoDCR for this layer so not compulsory. 

Shortcut Command : LCP 
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 _MainRoad 

Description : 

Draw a MainRoad as a closed polyline which is abutting the Plot Boundary . On the site that road is 

any type of road.such as any highway, street , lane, etc. over which the public have a right of passage 

or access or have passed and had access uninterruptedly for a specified period, whether existing or 

proposed in any scheme. Road name start with its width only. 

Shortcut Command : R1 

How to draw : - 

_Mainroad:- 

 Following rules will be applied on the objects of mainroad layer   
 Mainroad Width 
 Margin 
 Building height  
 Zone 
 Rewas projection  
 Precautions to be taken – 

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not get 

checked  
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 _MarginLine 

Description :  

No need to draw Margin Line, Just use Mark Margin tool for it. This layer is not provided for users. 

AutoDCR uses '_MarginLine' layer for it's own internal use. 

 _Nala 

Description :  

 Draw Nala polygon on this layer. 

Shortcut Command : R4 

How to draw : - 

_Nala:-  

 Following rules will be applied on the objects of Nala layer  
 Deduction   
 between nala to building Distance check  
 Precautions to be taken –  

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not get 

checked  
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 _NETPLOT  

Description :  

No need to draw NETPLOT. This layer is not provided for users. AutoDCR uses '_NETPLOT' layer 

for its own internal use.0 

_NDZ:- 

Description : - 

No Development zone area if any inside Plot Boundary  to be drawn on this layer. And it should be 

drawn inside the Plot Boundary  with text on _NDZ layer. 

Shortcut Command :  NDZ 

How to draw : - 

_NDZ:-  

 Following rules will be applied on the objects of NDZ layer  
 Reserve area 
 Deduction and additional in net Plot Boundary  area  
 Precautions to be taken –  

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
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 If this polyline has not been drawn and named correctly then all above rules will not 
get checked  

 

 

 

  

 

 

 

 

_NotInPossession :- 

Description :  

Plot Boundary  area which is not in possession or which is not in proposal to be drawn as a closed 

polyline on this layer. 

Shortcut Command: NIP 

How to draw : - 

_NotInPossession:-  

 Following rules will be applied on the objects of NotinPossesstion layer  
 Deduction  
 Precautions to be taken –  
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 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  

 

 

 

_OSReservation 

Description :  

 Draw OSReservation as closed polyline reserved as recreational space on this layer. With text on same 

layer. 

Shortcut Command : OSR 

How to draw : - 

_OSReservation :-  

 Following rules will be applied on the objects of OSReservation  layer   
 Balance Plot  
 Deduction in area calculation   
 Minimum OSReservation  area  
 Plot area in side OSReservation 
 Precautions to be taken – 
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 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not get 

checked  

 

 

 

 

 _Parking 

Description :  

Draw a parking poly as a closed polyline which is an enclosed covered or open area sufficient in size 

to park vehicles. This closed polyline shall contain a text on same _Parking layer. This text is treated 

as name of parking. Insert the parking by using a Insert-> Parking option. 

Shortcut Command : PK 

Parking Name : 

This closed polyline shall contain a text on same _Parking layer. This text is treated as name of 

parking. 
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  On this layer, you can group and insert any number of parking 

Parking Name 

Car Large CP-L 

Car Small CP-S 

Car CP 

Scooter SC 

Cycle CY 

Transportation vehicle TV 

Visitor's Parking ( Car ) VP 

How to draw : - 

_Parking:-  

 Following rules will be applied on the objects of Parking layer 
 Parking area  
 Staircase  
 Lift  
 Height  
 Size  
 Car, scooter, cycle, transport vehicle, visitor parking, ambulance      
 Precautions to be taken –  

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and “Insert  parking” correctly then all above 

rules will not get checked  
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_Passage 

Description :  

A closed polyline on _Passage represents a passage. It is a common passage or circulation space 

including a common entrance hall. This closed polyline contain a text. This text must be on "_Passage" 

layer. This text is treated as name of closed polyline. 

Centre Line :  

- All Passage poly must contain an Open Polyline inside that closed poly representing centre  line on 

"_Passage" Layer. But line type of center line must be 'Center line'. 

Shortcut Command : PAS 

How to draw: - 

_Passage:- 

 Following rules will be applied on the objects of Passage layer   
 Passage Width  
 Deduction  
 Taken in FSI 
 Center line  
 Precautions to be taken – 

 Draw polyline correctly. 
 Give name to this object from “Mark → Passage” option (From PreDCR Menu). 
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 If this object has not been marked properly then it won't be checked.   

 

 

 

_Plot  

Description: 

 Draw a Plot  poly as a closed polyline which is a parcel or piece of land enclosed by definite 

boundaries. A Plot will contain all Proposed Works (buildings, wings), open space, Internal Roads, 

Parking etc. The overall Plot Entity represent a Plan, AutoDCR refers it as 'Layout Plan'. The overall 

Plot  Entity represent a Plan, AutoDCR refer it as "Layout Plan". 

Shortcut Command: PLT 

How to draw :- 

_Plot:- 

 Following rules will be applied on the objects of Plot  layer  
 Minimum & maximum Plot  area  
 FSI 
 Amenity 
 Recreational ground  
 Internal road 
 Reserve area 
 Surrender to corporation 
 Access road  
 Road wideing   
 Encroached area  
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 Pathway  
 D.P road  
 Precautions to be taken – 

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not get 

checked  

 

_Podium 

Description :  

Podium shall be drawn on '_Podium' layer as a closed polyline. Podium should be inside Plot 

Boundary  covering proposed works if any. 

Shortcut Command : POD 

How to draw :- 

_Podium:-  

 Following rules will be applied on the objects of Podium layer 
 Parking  

 between  podium to Plot Boundary  boundary Distance check 

 Precautions to be taken –  
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 _PrintAdditionalDetail 

Description:  

Apart from the layers specified by PreDCR, any other information which user wants to display in 
final approval print shall be drawn on _PrintAdditionalDetail layer  

  

Shortcut Command: ADET 

How to draw: 
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_PropWork 

Description :  

Proposed Work is a building profile/outline and shall be drawn inside Plot Boundary. all detail 

Building plans (inside building polyline ) of all PWork( inside Plot Boundary  polyline) is 

associated/linked automatically by Auto-DCR by matching its name. 

  So for proper association it is required to follow specific standard as given. 

  XY (Z) 

  X is Wing name. 

  Y is wing number. 

  Z is Building name. 

For example if there are four wings A1,A2 & B1,B2 in building named "Monarch" then proposed 

work  names shall be - 

  A1 (Monarch), A2 (Monarch) 

  B1 (Monarch), B2 (Monarch) 

Reference Circle: All PWork poly must contain two circles (of any size) with its center on common 

point for whole building. First on layer of any FSI and second on Layer “_Floor”. These reference 

circles to be inserted from PreDCR -> insert-->Direction ref circles at the same location in all the 

floors as well as pwork in Plot Boundary.  Usually they can be placed inside either Common Lift or 

Stair/Inner Chowk (because generally their location is same on all floors). Reference circles are used 

by the software for overlapping all floor plans. 

Shortcut Command:- PW 

How to draw :- 

_PropWork:-  

 Following rules will be applied on the objects of PropWork layer 
 Margin   
 Coverage area 
 Propwork to Propwork distance  
 Propwork to parking distance  
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 Electrical line distance 
 electric sub-station distance 
 Septic tank     
 covered garage distance  
  Railline   
 Precautions to be taken –  

 Draw poly line properly and give name to this object from “Assign Name → Building & 
PropWork” Option? 

 If this polyline has not been drawn and named correctly then all above rules will not 
get checked  

 

 

 

_RailLine 

Description :  

Railway line shall be drawn as a non closed polyline with some text indicating gauge of rail line over 

it. 

Shortcut Command : L2 

How to draw : - 

_RailLine:-  
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 Following rules will be applied on the objects of Railline layer  
 Gauge  
 Precautions to be taken –  

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  

 

 

 

 

 

 

_Ramp 

Description :  

Draw a Ramp poly as a closed polyline in floor plans and/or Plot Boundary  and section. Naming 

convention for ramp is "---m. long and ---m. high ramp-1". give unique name to each ramp. 

Shortcut Command :- RP 

How to draw : - 

_Ramp:-  
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 Following rules will be applied on the objects of Ramp layer  
 Width  
 Slope  
 Precautions to be taken –  

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  

 

 

 

 

 

 

_RefugeArea:- 

Description :  

Refuse area to be drawn in plan as a closed polyline with text on this layer. Overlapped with FSI layer 

but outside the FSI poly. 

Shortcut Command :  

How to draw :  

_RefugeArea:-  

 Following rules will be applied on the objects of RefugeArea layer  
  Area  
  Width  
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  Height  
 Precautions to be taken –  

 Draw polyline correctly   
 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked 

 

 

 

_ReservArea 

Description :  

Reserved area (Reservation area in Development plan) shall be drawn on this layer if present in 

proposal. This can be any area reserved for/by Authority for future. 

Shortcut Command : RSA 

How to draw :- 

_ReservArea:-  

 Following rules will be applied on the objects of ReservArea layer  
 Reserve area 
 Deduction  
 Precautions to be taken –  

 Draw polyline correctly   
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 Give name to this object in same layer as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked 

 

 

 

 

_ResiFSI 

Description : - 

Draw a ResiFSI as a closed polyline which is the area covered by a building on all the floors. This FSI 

polyline only used for residential use building or floor. ResiFSI poly must be inside Floor poly. 

Shortcut Command : MFS 

How to draw : - 

_ResiFSI:- 

 Following rules will be applied on the objects of ResiFSI layer  
 Permissible Balcony area  
 Built up area 
 Permissible FSI 
 Carpet area             
 Staircase             
 Room area  
 Arch projection 
 Chowk 
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 Ventilation shaft 
 Passage 
 Lift 
 Terrace  
 Converge check  
 Precautions to be taken – 
 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get check. 

 

 

 

_RoadWidening 

Description :  

Draw a road widening polyline as a closed polyline which the Plot Boundary area is going to the road, 

that area   should be drawn on this layer. It should be inside the Plot Boundary  polyline. 
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Shortcut Command : R5 

How to draw : - 

_RoadWidening:- 

 Following rules will be applied on the objects of RoadWidening layer  
 In Area calculation  
 Deduction 
 Addishnal  
 Margin  
 Precautions to be taken –  

 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get check. 
 

 

 

_Room 

Description :  

A closed polyline on _Room layer represents a room. This closed polyline contain a text. This text 

must be on _Room layer. Room to be marked by assigning them names using Assign Name-> room 

option from PreDCR menu. 

Shortcut Command : RU 
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How to draw : - 

_Room:- 

 Following rules will be applied on the objects of room layer   
 Room size  
 Width  
 Depth 
 Door  
 ventilation 
 Balcony 
 Projection 
 Precautions to be taken – 

 Draw poly line properly and give name to this object from “Assign Name → “ROOM” 
Option? 

 If this polyline has not been drawn and named correctly then all above rules will not get 

check. 

 

_Right-of-Way  

Description :  -  

Draw a closed polyline on “_RightOfWay” to represent a Right Of way and text inside it 

representing its width. Layer should be inside or intersecting with Plot Boundary  poly 

Shortcut Command : ROW 
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How to draw : - 

_RightOfWay:- 

 Following rules will be applied on the objects of RightofWay layer 
 Width  
 Plot Boundary  
 Precautions to be taken –  

 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get check. 

 

  

_Sanitation 

Description :  

 Draw any sanitation entities on this layer. (E.g. , Kitchen sink etc..) Mark those entities by using 

PreDCR -> Insert -> Sanitation. 

Shortcut Command : SND 

 

_Section 

Description :  
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Draw a Section polyline as a closed poly of section boundary which contain all floors with stair cabin, 

Lift machine room, water tanks etc. as shown in the figure. Also write the name as "Section" in this 

section poly. 

In this closed poly of section draw sections of all floors with stair cabin, inner Chowk, Lift machine 

room, Ventilation shaft, water tanks etc. as shown in the figure. 

Also write the name as "Section" in this section poly. 

This section poly will present inside the building poly. 

Shortcut Command : SEC 

How to draw : - 

_Section:-  

 Following rules will be applied on the objects of Section layer  
 Name  
 All Floorinsection  
 Ground level 
  Lift height 
 Staircase cabin  
 Margin 
 Tenement number  
 Parking   
 Per floor area 
 Building height 
 Water tank  
 Precautions to be taken –   

 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get check. 
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_SewagLline 

Description: -  

  Drain Line shall be drawn as a open polyline on this layer. 

Shortcut Command : L5 

How to draw : -  
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_SitePlan 

Description : -  

Site plan if any to be drawn on this layer. This is only for reference. No verifications are done by 

AutoDCR for this layer. So not compulsory. 

Shortcut Command: - STP 

 

_SpecialUseFSI 

Description :- 

FSI ploy for all other building uses like educational, institutional etc. except ResiFSI, CommFSI &  

IndFSI use should be drawn on this layer. 

Shortcut Command : SUF 

How to draw : - 

SpecialFSI:- 

 Following rules will be applied on the objects of ResiFSI layer  
 Permissible Balcony area  
 Built up area 
 Permissible FSI 
 Carpet area             
 Staircase             
 Room area  
 Arch projection 
 Chock 
 Ventilation shaft 
 Passage 
 Lift 
 Terrace  
 Converge check  
 Precautions to be taken – 
 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked. 
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 _StairCase 

Description :  

StairCase: On this layer, Each StairCase poly shall have three lines for Flight Width, Intermediate 

Landing and Floor Landing on same layer. Mark these open polyline by using Mark-> Staircase 

option from PreDCR menu. Also draw in plan all the treads on this layer which is a open polyline. 

This closed polyline contains a text. This text must be on _Stair layer. This text is treated as name of 

closed polyline. On this layer, Each StairCase poly shall have three lines for Flight Width, 

Intermediate Landing and Floor Landing on same layer This can be mark by tool Mark > StairCase > 

intermediate landing etc. 

Shortcut Command : STR 

How to draw : - 

_Staircase:- 

 Following rules will be applied on the objects of staircase layer   
 At Mark on depend below rules check  
 Staircase area  
 Tread  
  No. On Flight 
 Rise height  
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 Floor landing  
 Midlanding  
 Flight width 
 No of rise  
 Ventilation  
 Free from FSI (paid & unpaid) 
 Taken in FSI 
 Fire staircase  
 Precautions to be taken –  

 Draw polyline correctly. 
 Give name to this object from “Mark → STAIRCASE” option (From PreDCR Menu). 

 If this polyline has not been drawn and marked correctly then all above rules will not 
get checked. 

 

 

 

_SubStructure 

Description :  

Draw various substructures on "_SubStructure" layer as a closed polyline. And mark it according to the 

requirement as Mark -> Substructure -> Society Office, from PreDCR menu. Sub-structures can be 

drawn inside Plot Boundary  or in floor plans. 

Shortcut Command :  SSTR 

How to draw : - 

_Substructure:-  
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 Following rules will be applied on the objects of Substructure layer  
 Depend on mark 
 Proposwork  distant  
 Deduction 
 Addition   
 Substructure area 
 Width  
 Depth  
 Allowed in margin Front, Rear, Side 
 Distains from main road 
 Distains from PlotBoundary  boundary 
  Distains from Building  
 Precautions to be taken –   

 Draw polyline correctly. 
 Give name to this object from “Mark → Projection” option (From PreDCR Menu). 

 If  this object has not been marked properly then it won't be checked.   

 

 

_Tank 

Description :  

A closed polyline on _Tank layer represents a water tank. Under Ground tank can be drawn in Floor or 

Layout plan. If it is drawn in Floor plan then it should be at bottom of GROUND FLOOR. Overhead 

tank can be drawn in TERRACE FLOOR. Tank should be drawn as per internal size or dimensions. 

Both the tank also draw in section also. 

Tank Name : - This closed polyline contain a text and must be in given format. This can also be done 

by tool Assign Name>Tank 
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  Tank Name+ Type +Capacity 

Tank Type Text 

Overhead water tank (O/H) 

Underground water 

tank 

(U/G) 

  For e.g. 

  TANK-1 (O/H) 

  TANK-2 (U/G) 

Under Ground tank can be drawn in Floor or Layout plan. If it is drawn in Floor plan then it should be 

at bottom of GROUND FLOOR. 

Overhead tank can be drawn in TERRACE FLOOR. Usually it is drawn on StairCase poly in 

TERRACE FLOOR. 

Shortcut Command : TNK 

How to draw : - 

_Tank:- 

 Following rules will be applied on the objects of Tank layer 
 Tank area  
 Width  
 Depth  
 Capacity  
 Precautions to be taken –   

 Draw poly line properly and give name to this object from “Assign Name → “TANK” 
Option? 

 If this polyline has not been drawn and named correctly then all above rules will not get 

check. 
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_TempStructure  

Description:  

 Area for temporary structures to be drawn as closed polyline with text on this layer  

Shortcut Command : TMPS 

How to draw : - 

_TempStructure:-  

 Following rules will be applied on the objects of TempStructure layer 
 Area check  
 Sent to bpams  
 Precautions to be taken –  

 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked. 
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_Terrace 

Description:  

Draw a Terrace as a closed polyline on _Terrace layer which is including parapet wall. 

Terrace can be present in:  

 Plot Boundary : It must overlap with PWork 

 Floor: It must be outside the ResiFSI. 

Shortcut Command : TER 

How to draw : - 

_Terrace:-  

 Following rules will be applied on the objects of Terrace layer 

 Deduction  

 Addition  

 AlterNet terrace  

 Covered terrace   

 Precautions to be taken –   

 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked. 
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 _Tree 

Description:  

Draw or insert Tree in plot on _Tree layer if it is present in plot. 

User can be insert tree block directly by using predcr menu bar insert option. 

Shortcut Command: TREE 

 

_VentilationShaft 

Description :  

Draw Ventilation shaft/duct area as a closed Polyline with Text. Inside FSIArea on _Ventilation shaft 

Layer. Only those shafts from which ventilation for habitable room is not taken should be drawn on 

this layer. 

Shortcut Command:- VS 

How to draw : - 

_ VentilationShaft:- 

 Following rules will be applied on the objects of VentilationShaft layer 
 Area  
 Width 
 Ventilation  
 Precautions to be taken –  
 Draw polyline correctly 
 Give name to this object in same layer as that of object   
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 If this polyline has not been drawn and named correctly then all  

      Above rules will not get checked.  

     Give name to this object in same layer as that of object  

            

         

           

 

 

  

 _Void 

Description : 

If the space is not Chowk then it can be void. All ducts (where ventilation is not taken) and double 

height rooms can be drawn in void layer. 

Shortcut Command : VD 

How to draw : - 

_Void:- 

 Following rules will be applied on the objects of Void layer 
 Only Deduction  
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 Precautions to be taken –  

 Draw polyline correctly  
 Give name to this object in same layer as that of object.  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked. 

 

 

_WaterLine 

Description :  

Draw a Water line as a open polyline to show Water supply. 

Shortcut Command : WL 

How to draw : - 

 

 

_Window 
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Description :  

Window is a closed Polyline which is drawn on "_Window" layer. Also you can insert a particular size 

poly for Window using Insert->Window from PreDCR menu. 

Shortcut Command : WND 

How to draw : - 

_Window:- 

 Following rules will be applied on the objects of Window layer 
 Width 
 Length  
 Height 
 Name  
 Precautions to be taken – 

 Draw polyline correctly   
 Give name to this object in same layer from “insert “option  as that of object  
 If this polyline has not been drawn and named correctly then all above rules will not 

get checked  
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Tool  

All/Remover Tool Tip (PDCRTOOLTIP): 

This command will activate the tool tips for PreDCR layers. 

 

Show Only DCR Layers: 

This command will turn off all the layers in the drawing except PreDCR layers.  

 

Building level layer (PDCRSBL): 

 This command will turn on all the building plan level layers in the drawing. 

 

Layout level layer (PDCRSLL): 

This command will turn on all the Layout plan level layers in the drawing. 

 

Show Only DCR Layers (PDCRSDL): 

This command will turn off all the layers in the drawing except DCR layers.  

  

Show Other Layers (PDCRSOL): 

This command will turn off all the DCR and PreDCR layers in the drawing. 

 

Show All layers (PDCRSAL); 

 This command will turn on all layers in the drawing. 

 

Calculate Total Area (PDCRCTA): 

This command will compute the total area of all selected closed polygons. 
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Calculate Deducted Area (PDCRCDA): 

This command will compute the area of closed polygon after deducting closed polygons found 

inside. 

           

 

Get All Inside Poly (PDCRFIP):  

This command will highlight all polygons, which found exactly inside selected polygon under test. 

  

Get All Overlapping Poly (PDCRGOP): 

This command will highlight all polygons, which are overlapping with selected polygon under test. 

  

Get All Intersecting Poly (PDCRGIP): 

This command will highlight all polygons, which are intersecting with selected polygon under 

test. 

  

Find Open Entities (PDCRFNDO):  

Highlight open entities on PreDCR layers. 

 

Find Closed Entities (PDCRFNDC):  

Highlight closed entities on PreDCR layer. 

 

Convent Arc in Plotline 
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Shortest distance (PDCRFSD):  

  This command will find the shortest distance between two entities. 

 

Spelling check (_spell):  

This tool is used for spelling checking. 

 

Find Object (PDCRFOBJ):  

This command zoom & highlight object of a given handle. 
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Commands 

Create New Project (PDCRNWP):  

This command will Create New project for current drawing. 

Here you have to select Type of Project as  

 Proposed Development. 

 

Note: It is always compulsory to add your drawing to new Project. 

 

 

Create AutoDCR Layers (PDCRCL):  

This command will create layers required for AutoDCR and as per the Project Type you have 

selected. 

 

Verify Drawing:  

 

This command will verify the current drawing as required by DCR specifications. 

 a) Verify Close Entities (PDCRVD): Verify that LWPOLYLINE entities on the selected layers are 

closed and contain one text . 
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B) Verify all drawing (PDCRVT): Use this command to verify the layout and building level 

objects in the current drawing plan.  

Major checks are as follows: 

 

In the "Verify All Drawing Dialog" you can select the layout or building objects to be checked. 

Then to view the result press OK button. PreDCR will start checking all corresponding objects in 

the currently open drawing and then display the status as OK or list of failed objects in the dialog 
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as shown in Figure. Failed Object Information.  

Check if these entities are drawn as closed LWPOLYLINE. 

Name text is given to all objects. 

Entities are placed exactly inside their parent objects (container). 

Naming conventions are followed properly. 

c) Objection List (PDCROLST): This command gives the list of all minimum required entities 

which are not there in your drawing. If all required entities found then it gives a message that 

“minimum required entities are present in drawing”. 

 

 Markings 

 

Marking adds some extra meaning in entity. Following commands are provided to mark different   

entities as per requirement.  

Mark-> Stair Case-> No of flight -> 3 flight 4 flight (PDCRSCFAB): Mark line inside staircase as a 

no of flight 3flight 4flight 

Mark-> Stair Case->Fire Escape Staircase (PDCRSCFAB): Mark line inside staircase as a fire 

escape staircase 

 

Mark-> Stair Case-> Fab /Spiral Staircase (PDCRSCFAB): Mark line inside staircase as a 

Fabricated or spiral staircase.  

Mark->Stair Case-> Common Stair (PDCRSCES): Mark> Common Stair   

     Mark Intermediate Landing (PDCRMIL): Mark line inside staircase as intermediate Landing.  

Mark->Stair Case Landing->Flight Width (PDCRMFW): Mark line inside staircase as Flight 

Width. 

Mark->Stair Case Landing->Floor Landing (PDCRMFL): Mark line inside staircase as Floor 

Landing.  

2) Mark->Lift--> Fire Lift (PDCRFL): Mark Lift as fire if fire lift is provided.  

  Mark->Lift--> Hydraulic (PDCRLHTP)> Free from FSI OR Taken in FSI > Mark Lift as 
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Hydraulic & it is free from FSI or taken in FSI.  

Mark->Lift--> Unmark (Default) (Default) (PDCRLTP) > Mark->Lift--> Unmark (Default)  

Mark->Passage->Open Covered (PDCRPOCP): Mark passage > as a Open Corridor  

3 Mark->passage-> Fire Escape Passage or Unmark (default) (PDCRPSUP): mark passage 

as a fire escape passage or Unmark (default) 

4 Mark->passage-> Unmark (Default)  (PDCRPSUP): mark passage as a Unmark (Default)    

  

 Mark-> ->FSI-> Existing FSI (PDCRCONES): Mark Residential or Commercial FSI as Existing FSI. 

Mark->FSI->Normal (Default) (PDCRUMFSI): Mark Residential or Commercial FSI as Normal 

FSI. 

            Mark->Carpet Area->Spitted Tenement (PDCRMSPLTT): Mark Carpet Area as Spitted 

tenement. 

Mark->Balcony->Enclosed Balcony (PDCRMENCBL): Mark Balcony as enclosed balcony. 

Mark->Balcony->Unmark (Default) (PDCRUMENCBL): Unmark the marked balcony. 

Mark->Parking->One stacked, tow stacked three stacked four stacked (PDCRUMENCBL): 

mark parking as a one stacked, tow stacked three stacked four stacked   

Mark->Projection-- > 

Mark->Projection->F.Bed (PDCRMBPROJ): Mark Projection as Flower Bed  

Mark->Projection->Chhajja/Cornice/Whether shade (PDCRMCJPROJ): Mark Projection as 

Chhajja/Cornice/Whether shade 

Mark->Projection->C .B -> (PDCRMLPROJ): Mark Projection as C.B in floor plan as well as in 

section .  

 Mark->Projection->Loft ->(PDCRMLPROJ): Mark Projection as Loft in floor plan as well as in 

section  

Mark->Projection->Canopy/ Porch   (PDCRMCBPROJ): Mark Projection as Canopy/ Porch    

Mark->Projection->Verandah (PDCRMCPROJ): Mark Projection as a Verandah       

Mark->Projection-> Normal (Default) (PDCRUMPROJ): Mark Projection as a Normal (default) 

Architectural projection. 

Mark->Road widening Taken in fsi or Unmark (default) (PDCRMRVIFSI): Mark-> Road 
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widening as a Taken in fsi or Unmark (default) 

Mark->Existing Structure ->To Be Retained ->Building or Substructure (PDCRMREXWD): 

Mark Existing structure as to be Retained Building or Substructure 

Mark->Existing Structure-> To be demolish (Default) (PDCRMRMREXWC): Mark Existing 

structure as to be Demolish. 

Mark->SubStructure-> Electric Meter Room/ Electric Sub-Station (PDCRMER ): Mark 

Substructure as an Electric meter room/ electric Sum-Station  

Mark->Substructure->Watchman Cabin    (PDCRMTRAN): Mark Sub Structure as an watchman 

cabin  

Mark->Substructure->Society Office (PDCRMOR): Mark Sub Structure as a Society office. 

Mark->SubStructure->Servant Quarter (PDCRMSQ): Mark Sub Structure as a servant quarter. 

Mark->SubStructure->Sanitary Block (PDCRMSB): Mark Sub Structure as a sanitary block. 

Mark->SubStructure -> Garage (PDCRMGRJ): Mark Sub Structure as a garage when garage is 

covered. 

Mark->Substructure -> Rain Water harvesting (PDCRMGRJ): Mark Sub Structure as a Rain 

Water harvesting  

Mark->Substructure -> A.C Plant Room (PDCRMGRJ): Mark Sub Structure as a A.C Plant Room 

Mark->Substructure -> Swimming Pool (PDCRMGRJ): Mark Sub Structure as a Swimming Pool  

Mark->Substructure -> Septic Tank/Soak pit (PDCRMGRJ): Mark Sub Structure as a Septic 

Tank/Soak pit   

Mark->Substructure ->Pump House-> (Above Ground) (PDCRMPR): Mark Sub Structure as a 

Pump House (Above Ground)  

Mark->Substructure ->Pump House-> (Below Ground) (PDCRMPR): Mark Sub Structure as a 

Pump House (Below Ground)    

Mark->Substructure ->Effluent Treatment Plant/ Std (PDCRMETP): Mark Sub Structure as a 

Effluent Treatment Plant std 

Mark->Substructure ->Dish Antenna room (PDCRMSPT): Mark Sub Structure as a Dish Antenna 

room  

Mark->Substructure -> Video Room (PDCRMSPT): Mark Sub Structure as a Video Room 

Mark->Substructure -> Out House (PDCRMSPT): Mark Sub Structure as a Out House  
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Mark->Substructure -> Will (PDCRMSPT): Mark Sub Structure as a Will  

Mark->Substructure -> Foyer (PDCRMSPT): Mark Sub Structure as a Foyer 

Mark->Substructure -> Cycle/Scooter Shelters (PDCRMSPT): Mark Sub Structure as a 

Cycle/Scooter Shelters  

Mark->Substructure -> Weigh Bridge (PDCRMSPT): Mark Sub Structure as a Weigh Bridge  

 Mark->Substructure -> Open Chemical Plant (PDCRMSPT): Mark Sub Structure as a Open 

Chemical Plant 

Mark->Substructure ->Telephone room (PDCRMSPT): Mark Sub Structure as a Telephone room  

Mark->Substructure -> Entrance gate (PDCRMSPT): Mark Sub Structure as a Entrance gate 

Mark->Substructure -> Explosive Storage (PDCRMSPT): Mark Sub Structure as a Explosive 

Storage 

Mark->Margin (PDCRMRGN): Use this command to define or mark the front, sides and rear 

margins of the Plot Boundary. . 

 

 

Insert entities 

Insert->Parking-> Car L (2.5 X 5.5) (PDCRICP) -> Use this command to insert car-parking poly 

of. at selected point. 

Insert->Parking-> Car S (2.3 X 4.5) (PDCRICP) -> Use this command to insert car-parking poly 

of. at selected point 

Insert->Parking-> Car S (3.5 X 7.5) (PDCRICP) -> Use this command to insert car-parking poly 

of. At selected point    
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Insert-> Parking-> Scooter (PDCRISP) ->Use this command to insert Scooter parking poly at 

selected point. 

Insert-> Parking-> Cycle (PDCRICY) ->Use this command to insert Cycle parking poly at 

selected point. 

             4.  Insert->Parking-> Transport Vehicle   (PDCRITV) ->Use this command to insert 

parking Transport Vehicle poly at selected point. 

            5.  Insert->Parking->Visitors Parking->Car (PDCRIVP) -> Use this command to insert 

visitor car parking poly at selected point 

             6.  Insert->Parking-> Loading/Unloading (PDCRIVP) -> Use this parking -> 

Loading/Unloading  

  

             7. Insert->Door (PDCRIDRNAM): Use this command to insert door poly at selected point 

and with specified size given by user. As soon as you use this command the following Dialog 

appears.   

           

8. Insert->Window (PDCRIWNDNAM): Use this command to insert window poly at selected 

point and with specified size given by user. 
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9. Insert-> Text (PDCRIWC): Use this command to insert sanitation text at selected point. Ex.   

Urinal, Wash basin Drinking water, washing tap, etc………. which is mark on then insert text by 

using sanitation text marking from insert menu. 

           10. Insert->Direction Reference Circle (PDCRIWC): Use this command to insert 

direction reference circle. Insert these circles in all the floor plans as well as in proposed work at 

the same & common place (e.g. Lift or Stair) of all the floors. 

 

Assign Name 

 

- There are few naming conventions required by AutoDCR, for which PreDCR provides the 

following tools: 

Assign Name->Building and proposed works (PDCRBLDPWNL): Use this command to give 

name for building poly and its associated proposed works. 

 

Assign Name->Tank (PDCRTNKNAM): Use this command to give name for Tank poly and its 

corresponding tanks. 
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Fill in the dialog and select the tank poly drawn in plan and the same drawn in section 

Assign Name->Room (PDCRASRUN): Use this command to give different names for Room poly. 

          

 

 

 

Assign Name->Floor Name  (PDCRASFLRNAM): Use this command for assigning name to a 

floor poly and it’s corresponding  floor in section poly in section. 
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Tools  

All/Remover Tool Tip (PDCRTOOLTIP): 

This command will activate the tool tips for PreDCR layers. 

Show Only DCR Layers: 

All PreDCR layers (PDCRSPL): 

This command will turn off all the layers in the drawing except PreDCR layers.  

Building level layer (PDCRSBL): 

 This command will turn on all the building plan level layers in the drawing. 

Layout level layer (PDCRSLL): This command will turn on all the Layout plan level layers in the 

drawing. 

Show Only DCR Layers (PDCRSDL): 

This command will turn off all the layers in the drawing except DCR layers.  

  

Show Other Layers (PDCRSOL): 

This command will turn off all the DCR and PreDCR layers in the drawing. 

 

Show All layers (PDCRSAL); 
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 This command will turn on all layers in the drawing. 

 

Calculate Total Area (PDCRCTA): 

This command will compute the total area of all selected closed polygons. 

 

 

Calculate Deducted Area (PDCRCDA): 

This command will compute the area of closed polygon after deducting closed polygons found 

inside. 

           

Get All Inside Poly (PDCRFIP):  

This command will highlight all polygons, which found exactly inside selected polygon under 

test. 

  

Get All Overlapping Poly (PDCRGOP): 

This command will highlight all polygons, which are overlapping with selected polygon under 

test. 

  

Get All Intersecting Poly (PDCRGIP): 
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This command will highlight all polygons, which are intersecting with selected polygon under 

test. 

  

Find Open Entities (PDCRFNDO): Highlight open entities on PreDCR layers. 

 

Find Closed Entities (PDCRFNDC): Highlight closed entities on PreDCR layer. 

 

Shortest distance (PDCRFSD):  

This command will find the shortest distance between two entities. 

 

Spelling check (_spell): This tool is used for spelling checking. 

 

Find Object (PDCRFOBJ): This command zoom & highlight object of a given handle. 

 

Set Default ACAD Version (PDCRSDA): 

 

 

PREDCR SHORT-CUT COMMANDS 

Layer name Description Naming 

Convention 

short 

command 

_PrintAdditionalDetail  Description: - Any additional 

details apart from details provided 

on all other PreDCR layers can be 

drawn on this layer. These details 

may not be necessary for actual 

scrutiny process but can be used 

as additional supporting 

information. 

 ADET  
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_Amenity Draw Amenity space as a closed 

polyline which is reserve for 

utilities, services and 

conveniences. 

 AMN 

_ArtiVentiShaft  Description: - Draw 

ArtiVentilation shaft/duct area as 

a closed Polyline with Text. Inside 

FSIArea on _ArtiVentiShaft Layer. 

Only those shafts from which 

ventilation for habitable room is 

not taken should be drawn on 

this layer. 

 AVS   

_ArchProj This layer is used to represent 

various Architectural Projections 

in your Plan. Draw a closed 

Polyline for Architectural 

Projections. And mark it using 

Mark->Projection from PreDCR 

menu, according to 

requirements. Canopy/porch will 

come in Plot Boundary & other 

projections will come with floor 

plans. 

 

Mark -> 

Projections -> 

Chajja 

 

AP 

_AutoFireAlarm Fire installation detail is should 

be shown on this layer  

 AFA 

_Auto Sprinkler  Fire installation detail is should 

be shown on this layer  
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_Balcony Draw a balcony as a closed 

polyline which is a horizontal 

projection including parapet to 

serve as a sitting out place. Name 

of balcony must be inside and on 

_Balcony layer. 

 

If Balcony is 

Enclosed Than 

Mark -> Balcony -> 

Enclosed Balcony 

 

BL 

_Building Building is used to group all floor 

plans of the same building.   

Draw a closed poly enclosing all 

the floor plans and section of the 

same building on _Building layer. 

Note: As written above, 

dimension or area of this 

building poly has no meaning in 

AutoDCR. This is just an logical 

group of all floors of the same 

building. If the building plans of 

multiple PWorks or wings are 

same then building name shall be 

as given aside. 

 

Naming 

Convention will be  

provided by 

Tool>Assign Name 

A (Bldg.Name) 

inside Bldg.Poly & 

A-1 (Bldg.Name) 

inside Pwork Poly 

BLD 

 

_Carpetarea 

Draw carpet area as a closed 

polyline which is a net usable 

floor area within a building 

excluding that covered by the 

walls or any other areas 

specifically exempted from floor 

space index computation in these 

regulations. 

If Carpetarea is 

Splitted – 

Tenement. 

Mark-> 

Carpetarea-> 

normal (default) 

 

CPT 
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_ChemStorageBoundary Fire installation detail is should 

be shown on this layer  

  

 _Chowk Draw a chowk as a closed 

polyline which is an enclosed 

space permanently open to the 

sky within a building at any level. 

From chowk we take ventilation 

for habitual rooms 

 CWK 

_CommFSI Draw a CommFSI as a closed 

polyline which is the area 

covered by a building on all the 

floors. This FSI polyline mainly 

used for commercial use bldg. 

 

No need to give 

name on this layer. 

CMFS 

_CompoundWall Closed polyline of compound 

wall to be drawn on this layer 

overlapping Plot Boundary .  

 

1.5m high 

compound wall 

CW 

_Down Comer  Fire installation detail is should 

be shown on this layer 

  

_Door  Door is a closed Polyline Which is 

drawn on “_Door” layer. Also you 

can insert a particular size poly 

for Door using Insert->Door from 

PreDCR menu. 

 

Insert-> Door 

DR 

_DryRiser  Fire installation detail is should 

be shown on this layer 

  

_Elect line 

 

 

 

Electric line will be present in the 

layout plan and shall pass 

through Plot Boundary  entity as 

a non closed polyline. 

 

33 KV High 

Tension Line 

L1 
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    Name electric line shall start 

with its voltage capacity and text 

insertion point shall lie on its 

polyline. 

_ExStructure Draw a Exstructure as a closed 

polyline which is a building or 

structure existing authorized 

before the commencement of 

these regulation. And mark it 

using Mark -> Existing structure 

as 'To be demolished' or 'To be 

retained’. 

 

Mark-> Existing 

Structure-> To be 

Demolished    OR   

To be Retained       

ES 

_FireExitinguisher Fire installation detail is should 

be shown on this layer  

  

_FloorInSection  Description : - Draw a Floor 
Inspection as a closed 
polyline which is the height 
of that floor (slab top to slab 
top) This poly only used for 
checking floor height. For 
assigning the name of 
FloorInSection then used 
Assigned name option for 
PreDCR tool menu. 

1.   Name of each floor 
section will be same as of 
floor in plan. 

2.   For one typical floor 
plan multiple floor 
section will be there. 

For e.g. for one typical floor 
plan for 1-3 floors there will 
three sections shall be drawn 
with name "First Floor Plan", 
"Second Floor Plan" and 

 SECF 



 

109      PreDCR help Manual : Chennai Metropolitan Devlopment Authority. 

 

109 PREDCR SHORT-CUT COMMANDS 

"Third Floor Plan" 
respectively. 

_Floor Floor poly should be drawn as a 

closed Polyline with Text on 

same Layer. This is just a logical 

Group of all floor Entities. 

           Floor Name: Floor Plan will 

be automatically link with 

Section by matching the Floor 

Name. Hence all names to be 

given using <Assign Name> 

function 

Naming 

Convention will be  

provided by 

Tool>Assign 

Name>Floor name 

 

Name of  floor 

should be in given 

format: 

TYPICAL-1,4 

FLOOR PLAN 

TYPICAL-1-5 

FLOOR PLAN 

TYPICAL-2&3 

FLOOR PLAN 

Ground Floor Plan 

FLR 

_Ground Level  The Ground level line should be 

drawn as an open polyline in the 

section poly. 

Prop.Ht. will be considered from 

GroundLvl Polyline 

 

No need to give 

name on this layer. 

  

GL  

_HoseReel Fire installation detail is should 

be shown on this layer  

  

_IndFSI   Draw a closed FSI Polyline, 

which is used as a Industrial 

Purpose. 

No need to give 

name on this layer.  

 

IFSI  
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_IntDPRoad  Description: - Draw a DP Road as 

a closed poly line with Text. (eg : 

any DProad passing from inside 

of the Plot Boundary )(Note: 

Road width must be written at 

the starting of Text). 

 R3 

_InternalRoad 

 

Draw each Internal Road as a 

closed Polyline with Centre Line 

(Ltype-CentreLine) & single text 

inside it. 

 

7.50 m wd. 

Internal Road 

R2 

_Lift 

 

Draw a Lift as a closed polyline 

which is a mechanically guided 

car, platform or transport for 

persons and materials between 

two or more levels in a vertical or 

substantially vertical direction 

 Fire Lift means a special lift 

designed for the use of fire 

service personnel in the event of 

fire or other emergency. 

Naming 

Convention will be  

provided by 

Tool<Mark>Lift 

 

If fire lift are 

provided then use 

the marking of " 

Fire >Hydraulic  or     

Unmark (default ) 

LFT 

_Location plan 

 

Location plans if any to be drawn 

on this layer. This is only for 

reference. No verifications are 

done by AutoDCR for this layer so 

not compulsory. 

 LCP 

_Margin line Margin Polylines will be created 

by PreDCR by using Tool 

"Mark>Margins" 

(User need not do anything on 

 L3 
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this layer.) 

_Main Road 

 

 

Draw Main Road as a closed Poly 

with Text, which should be 

abutting with the Plot Boundary  

closed Poly. 

(Note: Road width must be 

written at the starting of Text) 

 

24.00 m wd. Main 

Road 

R1 

_ManulFireAlarm 

 

Fire installation detail is should 

be shown on this layer  

  

_Nala Draw centre Line of Nala as an 

open Polyline on this layer. Name 

of the poly should contain width 

of the Nala 

 R4 

_Net Plot No need to draw NETPLOT. This 

layer is not provided for PreDCR 

users.. 

No need to give 

name on this layer. 

 

NPLT 

 

_NotInPossession  Plot Boundary  area which is not 

in possession or which is not in 

proposal to be drawn as a closed 

polyline on this layer.  

 NIP  

_OtherFireinst Fire installation detail is should 

be shown on this layer  

  

_Parking  Draw a closed Polyline for 

Parking on “_Parking” Layer. You 

can also use Insert function to 

insert desired Parking Poly in 

your drawing. 

Insert-> Parking-

>Car/Scooter/ 

Transport Vehicle/ 

Visitor Parking 

(Car) OR 

 

 PK 
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Loading/unloading 

_Passage 

  

Draw a closed polyline on 

“_Passage” Layer to represent 

passage with Centre Line (Ltype- 

CentreLine) & single text inside 

it. 

 

(Note: If Premium for Passage is 

going to be Paid, Passage should 

be marked by using Tool "Mark " 

 

Mark > Passage > 

covered Passage.> 

Free from FSI or 

Taken in FSI. 

Mark > Passage > 

Open Corridor 

Mark > Passage > 

Fire Escape 

Passage  

PAS  

_Pathway  Draw pathway as a closed 

polyline with text specifying its 

width.eg.1.5 m. wide pathway.  

 R6  

_Plot Boundary  

  

Description: - Draw a Plot 

Boundary  poly as a closed 

polyline which is a parcel or 

piece of land enclosed by definite 

boundaries. A Plot Boundary  will 

contain all Proposed Works 

(buildings, wings), open space, 

Internal Roads, Parking etc. The 

overall Plot Boundary  Entity 

represent a Plan, AutoDCR refers 

it as 'Layout Plan'. The overall 

Plot Boundary  Entity represent a 

Plan, AutoDCR refer it as "Layout 

Plan". 

 PLT 

_Podium Draw a closed polyline on  POD  
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 “_Podium“to represent Podium. 

It should be shown in the layout 

and not in floor plans 

 

_PropWork  PWork is a building profile and 

shall be drawn inside Plot 

Boundary . Draw a closed 

polyline for Proposed Work on 

“_PropWork” Layer. 

Tools > Assign 

Name >  

Building and 

PropWork.  

 

PW  

_RailLine  Railway line shall be drawn in 

the layout plan as a Open Poly & 

Text which insertion point lies 

on the Polyline. (Note: Railway 

Gauge must be written at a 

starting of Text)  

 

__ Meter Gauge 

Railway Line  

L2  

_Ramp 

  

 Draw a Ramp as a closed 

polyline with Centreline (L-type-

Centre) & Text inside it in Plan. 

10.0m long 1.5m 

high Ramp 

 

RP 

_RecrationalGround  Description: - Draw Open space 

as closed polyline reserved as 

recreational space on this layer. 

With text on same layer. 

 

 

OPS 

_RefugeArea 

 

A closed polyline with Text 

around the refuge area should be 

drawn on same Layer. 

Refuge area should be outside 

overlapped with FSI (ResiFSI, 

CommFSI) poly. 

 RFG 
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_ResiFSI Draw a ResiFSI as a closed 

polyline which is the area 

covered by a building on all the 

floors. This FSI polyline only  

used for residential use bldg or 

floor. 

 

No need to give 

name on this layer. 

MFS 

_RightOfWay  Description: - Draw a closed 

polyline on “_RightOfWay” to 

represent a Right Of way and 

text inside it representing its 

width. Layer should be inside or 

intersecting with Plot Boundary  

poly.  

 ROW  

_ReservArea If there in any Reservation Area 

in Plot Boundary , it should be 

drawn as a closed Polyline with 

Text inside same Layer. 

 RSA 

_RoadWidening Road Acquisition/Road 

Widening area shall be drawn as 

a closed Polyline with Text on 

same layer inside Plot Boundary  

Entity. Margin will be generated 

& checked from Roadwidening 

Poly by AutoDCR software. 

 R5 

_Room A closed polyline for each room 

with its text inside should be 

drawn on this layer. Text should 

be given using <Assign Name> 

function 

 

 

Assign Name > 

Room 

RU 
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_Sewageline  Description: - Drain/Sewage 

Line: - Sewage line shall be 

drawn as a open polyline on this 

layer.  

 L5  

_Section Section poly should be drawn as 

a closed Polyline with Text on 

same Layer. It is used to group all 

Sectional detail like 

FloorInSection, Plinth, Stair 

cabin, Tank etc. 

(This is just a logical Group of 

Sectional Entity).  

(Note: Area or size of Floor 

doesn't have any meaning in 

AutoDCR) 

 SEC 

_Sanitation  Description: - Draw any sanitation 

entities on this layer. ( e.g. Water 

closet , Kitchen sink etc..) Mark 

that entities by using PreDCR -> 

Insert -> Sanitation  

 SND  

_Separation Wall Fire installation detail is should be 

shown on this layer  

  

_Site Plan 

 

The encapsulating poly around 

the Site/Key Plan with the Text & 

Scale inside it.  

 

 

 

STP 
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_StairCase Total Staircase area should be 

drawn as a closed polyline with 

text inside it. 

This Main Stair Poly should 

contain Intermediate Landing, 

Floor Landing & Each Tread as an 

open polyline. 

Intermediate & Floor Landing 

Poly can be Marked by PreDCR 

Tool "Mark>Staircase>Int. or 

Floor Landing" 

(Note: If Premium for Staircase is 

going to be Paid, Staircase should 

be marked by using Tool 

"Mark>Staircase>Free from FSI" 

 

Mark-> Stair Case-

> No. of flight >3 

Flight or 4 Flight 

Fire Escape 

Staircase OR 

Fab/Spiral Stair 

 Staircase  and 

Common Stair 

Mark-> Staircase 

Landing-> Flight 

Width , 

Intermediate & 

Floor Landing 

STR 

_SpecialUseFSI A closed poly represents a other 

than Residential, commercial or 

Industrial use FSI or Floor FSI.  

It will cover whole area which is 

considered in FSI Area per Floor. 

 SUF 

_SubStructure SubStructures which are allowed 

in Margins or Layout & Free 

from FSI should be drawn as a 

closed polyline with text inside it. 

Name of the 

SubStructure can 

be assigned from 

Mark>SubStructure  

SSTR 

_Tank Tank clear size should be drawn 

as a closed Polyline with Text on 

this Layer in Floor Plan or Plot 

Boundary  as well as Section 

with same Text. 

Assign Name>Tank   TNK 



 

117      PreDCR help Manual : Chennai Metropolitan Devlopment Authority. 

 

117 PREDCR SHORT-CUT COMMANDS 

(Note: It should be in proper 

Naming convention which is 

Provide by Predcr by using Tool. 

_Terrace Closed polylines around the 

terraces to be drawn on this 

layer. If the terrace is used 

commonly by all tenements mark 

it as Common Terrace else it will 

be treated as Individual by 

default. 

 TER 

_TempStructure  Description: - Area for 

temporary structures to be 

drawn as closed polyline with 

text on this layer.  

 TMPS  

_Upper Setback   Description : - Draw a closed 

polyline in plan as well as in 

proposed work which having 

setbacks  

 

Mark-> Upper Set 

Back-> First OR 

Second  

USB  

_Void If the space is not Chowk then it 

can be void. All ducts (where 

ventilation is not taken) and 

double height rooms can be drawn 

in void layer. 

 VD 

_Waterline Draw a open polyline on 

“_WaterLine” to represent water 

lines. 

 L4 

_Wet Riser Fire installation detail is should be 

shown on this layer  
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_Window Draw a closed polyline on 

_Window” Layer to represent 

window. You can also use Insert 

tool to insert window poly for 

particular size. 

Insert > window WND 

_Yard Hydrant  Fire installation detail is should be 

shown on this layer 

   

 

 

Specifications to be followed-  

The drawing entities should be drawn on Automatic layers created by using PreDCR. 

Plot Boundary layout, detailed floor plan and building section for all the floors should be there in 

one AutoCAD drawing file.   

All building items like proposed Plot Boundary, proposed work, proposed parking etc must be 

drawn using closed polyline. 

(i.e. Every entity must be closed LWPOLYLINE except Railway Line , Drain line, Water Line, 

Electric Line, Dead Wall and Ground level.) 

Building Sub-Items must be exactly inside of outer closed polyline as per their place 

in architectural plan. 

This means none of the edge or vertex of inside entity should be drawn outside its container 

entity. For example Parking or Open Space poly must be exactly inside the main Plot Boundary  

poly. Tools are provided in PreDCR to verify this check.  

Every Building Sub-Items should be given a specific/unique name (Text or MText entity) on the 

same layer & inside the entity poly. As far as possible, this name should be unique. If name not 

found then AutoDCR will generate the name automatically. Naming Conventions should be 

followed properly. 

e.g.  Each Room should be given the concerned name Using <Assign Name> function of PreDCR 

Living, Kitchen, Bedroom. Etc. Floor Name: GROUND FLOOR; TYPICAL FLOOR 1,2 & 5-8; 

TERRACE FLOOR. Floor Items: Room Names should be given properly without using 
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abbreviations so the software can identify perfect entity. This can be done by Assign name facility 

provided by the software. 

User shall use only following kind of entities for Building Items: -  

LWPOLYLINE / TEXT / MTEXT 

If in a plan two proposed work are mirrored in that case user should provide two separate 

building plan for each proposed work. 

 

Sample cases 

 

Residential Bldg (Row house) 

 

 

 Residential bldg. (Single Detached with two buildings) 
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Commercial building 
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 Industrial Building 

 

Special building (School bldg) 
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Meaning of various PreDCR Messages 

“Entity contain more than one text"  

      It means Entity on this layer contain more than one text. So remove the extra text. PreDCR 

need only one text for one entity. 

 

"Entity not contain any text"  

       It means this entity not having any name/text, so give the name to this   entity on this layer 

 

"Polyline is not in a proper format"  

        It means Highlighted polyline not drawn properly. So redraw that polyline & check the 

properties of that polyline. 

"Entity is not closed"  

       It means the highlighted entities not a closed polyline so close it by using 'pedit' command. 

 

"Entity is supposed to inside one of the following entities"  
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       It means this highlighted entity should be present inside the one of the entities present in the 

given list“ 

 

"Entity is supposed to touching one of the following entities"  

      It means this highlighted entity is supposed to be touched one of the entities in given list 

 

"Entity should be outside overlapped with following entities“ 

      It means the highlighted entity should be outside overlapped with one of the th entities in the 

given list. 

“Entity must contain one of following entities“ 

      It means any one layer should be present inside in this entity which is listed. 

 

Following subentities are not found inside:  

     Direction Ref Point on layer _Floor, 

    Type: BLOCK, Color: ByLayer Status: 

    Common Point on layer _ResiFSI, 

    Type: BLOCK, Color: ByLayer Status: 

    It means insert the direction reference circles in side of that entities. 

 

"The corresponding Building not found with same name"  

     It means that proposed work not having building with same name. So assigned that building 

with having same name of proposed work. 

"Mark Substructures using PreDCR mark Substructure tool"   

        It means mark the substructure by using mark -> Substructure menu.  Do not type 

substructure name manually. 

 

"The lift machine room not found in building"  

        It means lift machine room having name not same in Plan & in section. 

 

"The lift poly is not suppose to be touch lift machine room"  
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        It means Lift machine room should be touch to lift poly in the section. 

 

 ‘Invalid objects, Please Try again"  

        It means If user marking balcony as a enclosed   but selecting layer of terrace then this 

message are getting. If selected entity is incorrect then invalid objects message are showing. So 

select correct layer for particular of that layer marking only 

"Section not found"  

      It means If all the floor plans are drawn but one of them in section floor are missing to 

converting floor in section layer then this message are getting. So draw all the floor plans with 

floor in sections. 

 

"The corresponding entities not found in section"  

      It means that listed entities not present in the section so show that entities in the section. 

 

"The corresponding entities not found in floor"  

      It means that listed entities not present in the floor so show that entities in the floor plan. 

 

“Two Tanks should not have same Name” 

      It means that two tanks not having a same name. So assigned two tanks by using Assigned 

name PreDCR menu. 

 

F.A.Q    (Frequently Ask questions) 

 

Hardware lock not found. 

1)   If user having Parallel port lock then they have to follow following steps. 

        Open My Computer -> C: Program files -> SEPL -> PreDCR -> Hlock 

        1.1. Open this Hlock folder & drvinstall -> click on install button & then click on Exit button. 

        1.2. Now open Checklock & click on check lock window. Check the return code & Description. 

If return code is 0 then u will get the Description is “ lock found” otherwise fixed the lock 
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properly.& do the step 1.1again & check the lock. 

 

If user having serial port lock (it’s look like pen drive)  

       2.1  Plug the Sentry USB Lock to any of the available USB Port on the PC. 

       2.2 The Found NEW HARDWARE WIZARD will be displayed. Click NEXT to continue.  

 

2.3.  Next window coming on screen will be of Choose your search and installation options in 

this window select the option Include this location in the Search. 
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2.4) Browse the correct path for the sentry USB driver (SentryUsb.sys) as e.g. C:\Program 

files\SEPL\PreDCR \ HLock  and click Next option. 

2.5) The next window you will get regarding waiting still installation after the installation is over 

the Next button will be highlighted click it. 
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2.6) Sentry USB device Drivers will be installed at this point Click Finish to complete the 

installation.  

 

 

2.7) Sentry USB Lock is now installed and ready to use. Sentry USB will be displayed in the Device 

Manager as below. 
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Internal error or Fatal error while verify the drawing 

     Copy that file and paste it into the new drg file & then verify. 

 

If Drawing is Automatically closed / crashed while marking any entity or verify complete drg. 

     Copy that file and paste it into the new drg file & then verify. 

 

 

 

While   performing verification if following massage comes, then follow the steps  

Check each layer separately  until you found problematic layer   
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